Power of Cryptography
Description
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers. Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find). Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10
101 and there exists an integer k, 1<=k<=10
9 such that k
n = p.
Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
Sample Input 2 16 3 27 7 4357186184021382204544 Sample Output 4 3 1234 Source |
[Submit] [Go Back] [Status] [Discuss]
题意就是求k^n=q中的k
换底公式可以乱搞之。。。。
尼玛。。。。
可以挑战高精度+二分呦
double 型的数据最长可以达到10^(-307) ~ 10^308 还是远大于题目要求的。。。
醉了
结果代码就变成了。。。几行。。。
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double a,b;
while(cin>>a>>b)
{
cout<<pow(b,1/a)<<endl;
}
return 0;
}