poj 2299 Ultra-QuickSort 树状数组求逆序数

这篇博客介绍了如何利用树状数组高效地解决 Ultra-QuickSort 算法中计算逆序数的问题,通过实例展示了输入与输出,并探讨了算法的来源。
摘要由CSDN通过智能技术生成
Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 46902 Accepted: 17116

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

求冒泡排序交换的次数

所求的数==逆序数的个数

统计一下,每个数之前有多少个比他大的数就可以,用树状数组存储一下,按从小到大的顺序排序,这个数在树状数组中+1,统计在新的排序顺序下每个数之前的区间和,也就有在这个数原来的位置之前有多少数比他小,用原来的位置-这个数就是这个数之前比他大的数 存到最后的答案中

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <set>
#include <string.h>
#include <math.h>
#include <stdlib.h>
using namespace std;
#define Max 500010
int lowbit(int a)
{
	return a&(-a);
}
int c[Max],v[Max];
struct pt
{
	int pos,val;
}e[Max];
long long n,sum;
bool cmp(pt a, pt b)
{
	return a.val<b.val;
}
void update(int x)
{
	while(x<=n)
	{
		c[x]+=1;
		x+=lowbit(x);
	}
	return ;
}
int getsum(int x)
{
	int res=0;
	while(x>0)
	{
		res+=c[x];
		x-=lowbit(x);
	}
	return res;
}
int main()
{
	while(cin>>n)
	{
		if(n==0) break;
		for(int i=1;i<=n;i++)
		{
			cin>>e[i].val;
			e[i].pos=i;
		}
		sum=0;
		sort(e+1,e+n+1,cmp);
		memset(c,0,sizeof(c));
		for(int i=1;i<=n;i++) v[e[i].pos]=i;
		for(int i=1;i<=n;i++)
		{
			update(v[i]);
			sum+=i-getsum(v[i]);
		}
		cout<<sum<<endl;
	}
	return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值