nyoj--58--最少步数(bfs&dfs)

最少步数

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11

dfs:

 C++ Code 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
#include<bits/stdc++.h>
using  namespace std;
int dx[ 4] = { - 1100};
int dy[ 4] = { 00, - 11};
int c, step, ex, ey;
int Map[ 9][ 9] = {  111111111,
                   100100101,
                   100110001,
                   101011011,
                   100001001,
                   110101001,
                   110101001,
                   110100001,
                   111111111
                };
void dfs( int x,  int y,  int c)
{
     if(x == ex && y == ey)
    {
         if(c < step)
            step = c;
    }
     for( int i =  0; i <  4; i++)
    {
         int xx = x + dx[i];
         int yy = y + dy[i];
         if(Map[xx][yy] ==  0 && c < step -  1)
        {
            Map[xx][yy] =  1;
            dfs(xx, yy, c +  1);
            Map[xx][yy] =  0;
        }
    }
}

int main()
{
     int t;
    scanf( "%d", &t);
     while(t--)
    {
         int x, y;
        c =  0;
        step =  9999;
        scanf( "%d %d %d %d", &x, &y, &ex, &ey);
        Map[x][y] =  1;
        dfs(x, y, c);
        Map[x][y] =  0;
        printf( "%d\n", step);
    }
     return  0;
}

bfs:


 C++ Code 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
#include<bits/stdc++.h>
using  namespace std;
int dx[ 4] = { - 1100};
int dy[ 4] = { 00, - 11};
int c, step, ex, ey;
int x, y;
int vis[ 9][ 9];
int Map[ 9][ 9] = {  111111111,
                   100100101,
                   100110001,
                   101011011,
                   100001001,
                   110101001,
                   110101001,
                   110100001,
                   111111111
                };
struct node
{
     int x, y, step;
};

int bfs()
{
    queue <node >qu;

    node s, now, next;  ///s为第一个访问的节点
    s.x = x;
    s.y = y;
    s.step =  0;

    vis[x][y] =  1///对访问过的点进行标记

    qu.push(s); ///第一个点入队
     while(!qu.empty())
    {
        now = qu.front();  ///把正在访问的点提出来
        qu.pop();   ///提出来后进行出队操作,把他相邻符合条件的点全部入队
         ///找到终点
         if(now.x == ex && now.y == ey)
             return now.step;

         for( int i =  0; i <  4; i++)
        {
            next.x = now.x + dx[i];
            next.y = now.y + dy[i];
            next.step = now.step;

             if(Map[next.x][next.y] ==  0 && vis[next.x][next.y] ==  0)
            {
                vis[next.x][next.y] =  1;
                next.step +=  1;
                qu.push(next);
            }
        }
    }
}
int main()
{
     int t;
    scanf( "%d", &t);
     while(t--)
    {
        memset(vis,  0sizeof(vis));
        scanf( "%d %d %d %d", &x, &y, &ex, &ey);
        printf( "%d\n", bfs());
    }
     return  0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值