PAT甲级--A1046.Shortest Distance

题目:1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

 

我的原本代码:

​
#include <cstdio>

int main()
{
    int N, M, a[100001] = { 0 }, b = 0, c = 0, sum = 0, all = 0;
    scanf("%d", &N);
    for (int i = 1; i <=N; i++) {
        scanf("%d", &a[i]);
        all += a[i];
    }
    scanf("%d", &M);
    for (int i = 1; i <= M; i++) {
        scanf("%d%d", &b, &c);
        if (b < c) {
            for (int j = b; j < c; j++) {
                sum += a[j];
            }
            if (sum > (all - sum)) {
                printf("%d\n", all - sum);
            }
            else {
                printf("%d\n", sum);
            }
            sum = 0;

        }
        else {
            for (int j = c; j < b; j++) {
                sum += a[j];
            }
            if (sum > (all - sum)) {
                printf("%d\n", all - sum);
            }
            else {
                printf("%d\n", sum);
            }
            sum = 0;

        }
    }
    return 0;
}

​

在极端情况下会超时!!!!

改进后的代码:

#include <cstdio>

int main()
{
    int N, M, a[100001] = { 0 }, dist[10001] = { 0 },b = 0, c = 0, sum = 0, all = 0;
    scanf("%d", &N);
    for (int i = 1; i <=N; i++) {
        scanf("%d", &a[i]);
        all += a[i];
        dist[i] = all;
    }
    scanf("%d", &M);
    for (int i = 1; i <= M; i++) {
        scanf("%d%d", &b, &c);
        if (b < c) {
            sum = dist[c - 1] - dist[b-1];
            if (sum > (all - sum)) {
                printf("%d\n", all - sum);
            }
            else {
                printf("%d\n", sum);
            }
            sum = 0;

        }
        else {
            sum = dist[b - 1] - dist[c - 1];
            if (sum > (all - sum)) {
                printf("%d\n", all - sum);
            }
            else {
                printf("%d\n", sum);
            }
            sum = 0;

        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值