PAT - 甲级 - 1046. Shortest Distance (20)(模拟)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7


给定条件:
1.给定一个环,这个换上有n个点
2.给定相邻点之间的距离

要求:
1.从a点到b点的距离最短是多少

求解:
1.从a到b只有正反两条路
2.求出其中一条,环的长度减去它就是另一条长度
3.输出较短一条

注意:
1.每次都去循环计算a到b的距离会超时
2.可以提前预处理好从0点到各个点的距离(一个方向即可)
3.a到b的距离就是 0到b的距离 - 0到a的距离


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n, k, a, b, mindis, sumdis;
int dis[100010];
int distot[100010];

int main() {
	mindis = sumdis = 0;
	fill(distot, distot+100010, 0);

	scanf("%d", &n);
	for(int i = 1; i <= n; i++) {
		scanf("%d", &dis[i]);
		sumdis += dis[i];
		distot[i] = dis[i-1] + distot[i-1];
	}

	scanf("%d", &k);
	for(int i = 0; i < k; i++) {
		mindis = 0;
		scanf("%d%d", &a, &b);
		if(a > b) swap(a,b);
		mindis = distot[b] - distot[a];
		mindis = min(mindis, sumdis - mindis);
		printf("%d\n", mindis);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值