POJ 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 64397 Accepted: 20226

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


= =|| 训练队同队的队员AC之后一直在向我炫耀 估计也是做不成队友了(手动再见)

初学STL写的不太好,刚开始还忘记了n>k的情况

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;


bool vis[200001];

typedef struct
{
    int data,step;
}position;
position father,current;


queue<position> bus;

int vplus,vreduce,vadd;

int main(void)
{
    int n,k;
    scanf("%d %d",&n,&k);
	if(n==k)
	{
		printf("0\n");
		return 0;
	}
	if(n>k)
	{
		printf("%d\n",n-k);
		return 0;
	}
    current.step=0;
    current.data=n;
    bus.push(current);
    while(!bus.empty())
    {
        father=bus.front();
        bus.pop();
        if(father.data==k)
        {
			printf("%d\n",father.step);
			return 0;
        }
        vis[father.data]=true;
        vplus=father.data+father.data;
        vreduce=father.data-1;
        vadd=father.data+1;
        current.step=father.step+1;
        if(vplus<200001&&!vis[vplus])
        {
            current.data=vplus;
            bus.push(current);
        }
        if(vadd<200001&&!vis[vadd])
        {
            current.data=vadd;
            bus.push(current);
        }
        if(vreduce>-1&&!vis[vreduce])
        {
            current.data=vreduce;
            bus.push(current);
        }
    }

    return (0);
}

下面是在其他地方找到的一份代码,也AC了不过时间好短w
#include<iostream>
#include<queue>
using namespace std;
#define M 100001
#define INF 10000000

struct POINT
{
	int pos;
	int step;
}now,next;
queue<POINT>Q;
bool visited[M];

int n,k;
int bfs()
{
	while(!Q.empty())
		Q.pop();
	now.pos=n;
	now.step=0;
	visited[now.pos]=true;
	Q.push(now);
	while(!Q.empty())
	{
		now=Q.front();
		Q.pop();
		next=now;
		for(int i=0;i<3;i++)
		{
			if(i==0) 
				next.pos=now.pos+1;
			if(i==1)
				next.pos=now.pos-1;
			if(i==2)
				next.pos=now.pos*2;
			next.step=now.step+1;
			if(next.pos==k)
				return next.step;
			if(next.pos<0||next.pos>M)
				continue;
			if(!visited[next.pos])
			{
				visited[next.pos]=true;
				Q.push(next);
			}
		}
	}
	return INF;
}

int main()
{
	while(cin>>n>>k)
	{
		memset(visited,false,sizeof(visited));
		if(n<k)
			cout<<bfs()<<endl;
		if(n==k)
			cout<<0<<endl;
		if(n>k)
			cout<<n-k<<endl;
	}
}

>_< 继续学习www
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值