1102 Invert a Binary Tree(25 分)(cj)

1102 Invert a Binary Tree(25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
int tree[12][2];
bool vis[12];
void init();
void inorder(int pos);
void invert(int pos);
void levelorder(int pos);
int main() {
	int n;
	char a, b;
	cin >> n;
	init();
	for (int i = 0; i < n; ++i) {
		cin >> a >> b;
		if(a != '-') tree[i][0] = a-'0';
		if(b != '-') tree[i][1] = b-'0';
		vis[b-'0'] = 1;
		vis[a-'0'] = 1;
	}
	int root;
	for (int i = 0; i < n; ++i) {
		if (vis[i] == 0) root = i;
	}
	invert(root);
	levelorder(root);
	cout << endl;
	inorder(root);
	system("pause");
	return 0;
}
void init() {
	for (int i = 0; i < 12; ++i) {
		tree[i][0] = -1;
		tree[i][1] = -1;
	}
}
void invert(int pos) {
	if (pos == -1) return;
	int x = tree[pos][0];
	tree[pos][0] = tree[pos][1];
	tree[pos][1] = x;
	invert(tree[pos][0]);
	invert(tree[pos][1]);
}
void inorder(int pos) {
	static bool f = 1;
	if (pos == -1) return;
	inorder(tree[pos][0]);
	if (f) f = 0;
	else cout << ' ';
	cout << pos ;
	inorder(tree[pos][1]);
}
void levelorder(int pos) {
	queue<int> q;
	q.push(pos);
	bool f = 1;
	while (!q.empty()) {
		int x = q.front();
		q.pop();
		if (f) f = 0;
		else cout << ' ';
		cout << x;
		if (tree[x][0] != -1) q.push(tree[x][0]);
		if (tree[x][1] != -1) q.push(tree[x][1]);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值