PAT 19秋 7-1 Forever (20分)

10 篇文章 0 订阅
该博客讨论了PAT编程竞赛中的一道题目,要求找到满足特定条件的'Forever Number',即数字A,其各位数字之和为m,A+1的各位数字之和为n,且m和n的最大公约数大于2且为素数。博主提出了一种通过枚举前K-2位数字来解决由于K范围较大而不能直接暴力枚举的策略。
摘要由CSDN通过智能技术生成

7-1 Forever (20分)

"Forever number" is a positive integer A with K digits, satisfying the following constrains:

  • the sum of all the digits of A is m;
  • the sum of all the digits of A+1 is n; and
  • the greatest common divisor of m and n is a prime number which is greater than 2.

Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

第一反应肯定是直接暴力枚举,但是K的范围大了些。

可以通过打表找规律发现最后两位都是99 ,所以可以只枚举前K-2位,这样数据是刚好的。

因为太久没做过打表题,都忘了还有这个牛逼的技能。

 

#include <bits/stdc++.h>
#define rep(i,a,n) for(int i=a;i<n;i++)
#define reo(i,a,n) for(int i=a;i<=n;i++)
#define INF 0x3f3f3f3f
#define ll long long
using namespace std;
const int N=1e3+5;
const int M=1e3+5;

int n,m,k;

int sumDig(int x){
    int sum=0;
    while(x){
        sum+=x%10;
        x/=10;
    }
    return sum;
}

int gcd(int a,int b){
    return b? gcd(b,a%b):a;
}

bool isPrime(int x){
    if(x<=2) return false;
    for(int i=2;i*i<=x;i++){
        if(x%i==0) return false;
    }
    return true;
}

struct node{
    int n,A;
};

vector<node>ans;
bool cmp(node a,node b){
    if(a.n!=b.n) return a.n<b.n;
    return a.A<b.A;
}
void gao(){
    ans.clear();
    for(int i=pow(10,k-3);i<=pow(10,k-2)-1;i++){
        if(sumDig(i)+18==m){
            int x=sumDig(i+1);
            if(isPrime(gcd(x,m))){
                ans.push_back({x,i*100+99});
            }
        }
    }
}

int main(){
    int M;
    cin>>M;
    reo(cas,1,M){
        cin>>k>>m;
        printf("Case %d\n",cas);
        gao();
        if(ans.size()==0) cout<<"No Solution"<<endl;
        else{
            sort(ans.begin(),ans.end(),cmp);
            rep(j,0,ans.size()){
                cout<<ans[j].n<<" "<<ans[j].A<<endl;
            }
        }
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值