让气球飞一会儿(hdu1004)

杭电1004

题目:

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73568    Accepted Submission(s): 27482


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
      
      
5 green red blue red red 3 pink orange pink 0
 

Sample Output
      
      
red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining
 

Statistic |  Submit |  Discuss | Note
Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2014 HDU ACM Team. All Rights Reserved.
Designer & Developer:Wang Rongtao LinLe GaoJie GanLu
Total 0.000744(s) query 1, Server time : 2014-08-04 17:36:18, Gzip enabled

 

 

中文大意:

让气球上升

比赛时间............................................................(描述略)!

输入:先输入N,表示N组颜色,接下来有N组数据,(最多有1000组颜色,每个小于15字符)

输出:输出出现次数最多的一项(占一行)

 

解题思路:

输入:用二维数组存储;

计算:用每一个与后面的比较,找出出现次数最多的一项

输出:将对应颜色输出

 

关键点:

数据的存储,以及颜色的记录;

再者就是使程序更快运行,可用一个数组对前面已经出现过且已经参与比较的颜色进行标记,当轮到她与后面的比较的时候,就可以跳过,(因为它与后面相同颜色的个数一定小于前面已经出现过的那个,所以无需比较)

本题还有就是,当所有的颜色都能不一样的时候,输出第一个!

具体代码实现如下:

 

//xiao ceshi
# include<stdio.h>
# include<string.h>
#define M 2000
char a[M+10][20];
char k[M+10];

int main(){
 int n;
 int i,j;
 int max,s,t;
 while(scanf("%d",&n)&&n){
  getchar();
  max=1;
  t=0;
  memset(k,0,sizeof(k));
  for(i=0;i<n;i++){
   gets(a[i]);
  }
  for(i=0;i<n-1;i++){
   if(k[i])     
   continue;
   s=1;
   for(j=i+1;j<n;j++){
    if(!strcmp(a[i],a[j])){
     k[j]=1;
     s++;
    }
   }
   if(s>max){
    max=s;     //记录数量
    t=i;     //记录下标
   }
  }
  puts(a[t]);
 }
 return 0;
}
  

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值