已知二叉树的中序前序遍历,还原树结构+层次遍历


L2-011. 玩转二叉树

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
题目链接

代码:


#include <iostream>
#include <cstdio>
#include <iomanip>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define LL long long
using namespace std;
struct node{
    int id;
    struct node *lc,*rc;
}*root,*k;
queue<struct node*> ans;
int mid[50],fr[50];

void build(struct node* &a,int k,int l,int r){//已知前序遍历和中序遍历,求原树
    int m;
    a=(struct node*)malloc(sizeof(struct node));
    a->lc=a->rc=NULL;
    a->id=fr[k];
    for(int i=l;i<=r;i++){
        if(mid[i]==fr[k]){
            m=i;break;
        }
    }//cout<<l<<r<<m<<endl;
    if(m>l)build(a->lc,k+1,l,m-1);
    if(m<r)build(a->rc,k+m-l+1,m+1,r);
}
//void dfs(struct node* r){
//    if(r==NULL)return;
//    cout<<r->id<<" ";
//    dfs(r->lc);
//    dfs(r->rc);
//}
void rev(struct node* rt){//翻转每个节点的lc、rc
    if(rt==NULL)return;
    swap(rt->lc,rt->rc);
    rev(rt->lc);
    rev(rt->rc);
}
int main()
{
    int n,cur=0;
    cin>>n;
    for(int i=1;i<=n;i++)scanf("%d",mid+i);
    for(int j=1;j<=n;j++)scanf("%d",fr+j);
    build(root,1,1,n);
    //cout<<root->id<<endl;
    //dfs(root);
    rev(root);
    while(!ans.empty())ans.pop();
    ans.push(root);
    while(!ans.empty()){//层次遍历
        k=ans.front();
        ans.pop();
        if(!cur)cur=1;
        else cout<<" ";
        cout<<k->id;
        if(k->lc)ans.push(k->lc);
        if(k->rc)ans.push(k->rc);
    }
    cout<<endl;

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值