poj1047 大数乘法

 

Round and Round We Go
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6796 Accepted: 3045

Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table:
142857 *1 = 142857
142857 *2 = 285714
142857 *3 = 428571
142857 *4 = 571428
142857 *5 = 714285
142857 *6 = 857142

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.

Sample Input

142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

=============================================================================

Source Code

Problem: 1047 User: knzeus
Memory: 204K Time: 16MS
Language: C++ Result: Accepted

  • Source Code
    #include <iostream>
    #include <cassert>
    #include <cstring>
    
    #define MAX_LEN   60
    
    //num_a和num_b是两个数字字符串,长度在2到60之间 
    bool isCyclic(char *num_a, char *num_b)
    {
         assert(num_a != NULL && num_b != NULL);
         int len_a = strlen(num_a);
         int len_b = strlen(num_b);
         if(len_a != len_b){
             return false;
         }
         for (int i=0;i<len_b;++i){
             char *pa = num_a;
             char *pb = num_b + i;
             while(*pa && *pa == *pb){
                  ++pa;
                  ++pb;
                  if(!*pb){
                      pb = num_b;
                  }
             }
             if(!*pa) return true;
         }
         return false;
    }
    
    int multiplication_table[10][MAX_LEN+1];
    
    void init_multiplication_table()
    {
         for(int i=0;i<10;++i){
             for(int j=0;j<MAX_LEN+1;++j){
                 multiplication_table[i][j] = i * j;    
             }    
         }
    }
    
    //product_rslt = multiplier * mulitplicant, 如果product_rslt的长度大于multiplier则返回false
    //否则返回真,并将product_rslt设置为乘积。 
    bool bigint_multiply(char *multiplier, int len, char *product_rslt, int multiplicant)
    {
         if(multiplication_table[*multiplier - '0'][multiplicant] >= 10) return false;
         
         //int len = strlen(multiplier);
         memset(product_rslt, 0, (len + 1) * sizeof(char));
         
         char *pc = multiplier + len - 1;
         product_rslt[len] = '/0';
         for(int i=len-1;i>=0;--i){
                 int prod = multiplication_table[*pc - '0'][multiplicant];
                 if(i==0 && prod >= 10) return false;
                 product_rslt[i] += '0' + prod % 10;
                 if(product_rslt[i] > '9'){
                       if(i == 0) return false;
                       int over = (product_rslt[i] - '0') / 10;
                       product_rslt[i] -= 10 * over;
                       product_rslt[i-1] += over;
                 }
                 product_rslt[i-1] += prod / 10;
                 --pc;
         }
         return true;
    }
    
    //判断由字符串表示的长正整数是不是满足*i循环等价的。 
    bool isCyclic(char *num)
    {
         assert(num != NULL);
         
         int len = strlen(num);
         char product_rslt[MAX_LEN + 2];
         
         for (int i=1;i<=len;++i){
             memset(product_rslt, 0, sizeof product_rslt);
             if(!bigint_multiply(num, len, product_rslt, i)) return false;
             if(!isCyclic(num, product_rslt)) return false;
         }
         
         return true;
    }
    
    
    int main()
    {  
        init_multiplication_table();
        
        char multiplier[MAX_LEN + 2];
        while(std::cin >> multiplier){
             std::cout << multiplier << " is";
             if(!isCyclic(multiplier)){
                   std::cout << " not";
             }
             std::cout << " cyclic/n";
        }
    
        return 0;
    }
    
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值