POJ 1001 Exponentiation 大数乘法模拟

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 159520 Accepted: 38882

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want

/*while(scanf(%s%d",s,&n)!=EOF) //this also work    */

{

...

}

Source


    题意:求取小数的n次幂,直接乘的话会丢失精度。

    分析:使用数组保存,模拟大数乘法。原理不复杂,过程略繁琐,见AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=6;
char s[maxn];
int  a[30*maxn],b[30*maxn],temp[30*maxn];
int main()
{
	int n;
	while(~scanf("%s %d",s,&n))
	{
		memset(a,0,sizeof(a));
		int numxsd=0;  //记录 小数点的位数
		int sum=0;     //记录小数部分的和  如果小数部分和为0 则说明为整数
		for(int i=5; i>=0; i--)
			if(s[i]!='.')
			{
				numxsd++;
				sum+=s[i]-'0';
			}
			else
				break;
		if(sum==0)//整数情况
		{
			int flagd,N=s[0]-'0';//记录乘数
			for(int i=1; i<=5; i++)
				if(s[i]!='.')
				{
					N*=10;
					N+=s[i]-'0';
				}
				else
					break;
			long long res=1;
			for(int i=0; i<n; i++)//直接累乘即可
				res*=N;
			printf("%lld\n",res);
			continue;
		}
		int num=0;//不考虑小数点  直接当作整数乘
		for(int i=5; i>=0; i--) //将数逆序保存在a 
			if(s[i]!='.')
				a[num++]=s[i]-'0';
		memset(b,0,sizeof(b));
		for(int i=0; i<num; i++)
			b[i]=a[i];  //用数组b保存乘数
		for(int k=0; k<n-1; k++) //  每一步  a*b=temp  temp再赋值a
		{
			memset(temp,0,sizeof(temp));//每次都初始化temp数组
			int flag; //标记第一个不是0的位置
			for(int i=30*maxn-1; i>=0; i--)
				if(a[i]!=0)
				{
					flag=i;
					break; //找到a[i]截止位置
				}
			for(int i=0; i<=flag; i++)
				for(int j=0; j<num; j++)
					temp[i+j]+=a[i]*b[j];//计算出temp
			for(int i=0; i<30*maxn-2; i++)//对temp 进行处理
				if(temp[i]>=10)
				{
					temp[i+1]+=temp[i]/10;
					temp[i]%=10;
				}
			for(int i=0; i<30*maxn; i++)//temp赋值给a
				a[i]=temp[i];
		}
		int flag0=0;//记录后导零位置
		for(int i=0; i<30*maxn; i++)  
			if(a[i]!=0)
			{
				flag0=i;
				break;
			}
		int flag;
		for(int i=30*maxn-1; i>=0; i--)//前导0位置 
			if(a[i]!=0)
			{
				flag=i;
				break;
			}
		int xsd=n*numxsd;//小数点的位置 
		for(int i=flag; i>=xsd; i--)
			printf("%d",a[i]);
		printf(".");//打印小数点 
		for(int i=xsd-1; i>=flag0; i--)
			printf("%d",a[i]);
		printf("\n");
	}
	return 0;
}
     单纯的模拟大数过程的题目,大数这方面的题目需要多练习。

     特记下,以备后日回顾。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值