1065 A+B and C (64bit) 溢出问题

Given three integers A, B and C in( -2^{63},2^{63}), you are supposed to tell whether A+B>C.

 

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

易错点:

long long 型的取值范围是[ -2^{63},2^{63} ),单个输入在该范围内,但是两个数相加可能会溢出,两个正数相加得到负数结果是正溢出,一定更大;两个负数相加得到非负数就是负溢出,一定更小;

代码:

#include <stdio.h>
int main()
{
	int n; 
	
	long long a[12][4]={0};
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%lld%lld%lld",&a[i][0],&a[i][1],&a[i][2]);
		bool flag;
		if(a[i][0]>0 && a[i][1]>0 && (a[i][0]+a[i][1])<0)
			flag = true;
		else if(a[i][0]<0 && a[i][1]<0 && (a[i][0]+a[i][1])>=0)//注意是大于等于0
			flag = false;
		else if((a[i][0]+a[i][1])>a[i][2])
		{
			flag = true;
		}
		else flag =false;
		if(flag) printf("Case #%d: true\n",i);
		else printf("Case #%d: false\n",i);
	} 
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值