Catch That Cow 追牛

Catch That Cow

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 143   Accepted Submission(s) : 35
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input
Line 1: Two space-separated integers: <i>N</i> and <i>K</i>
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
 
 
4

    人追牛,可以 +1,-1,*2,三种方法前进,问最短时间。

要注意的几点:

    走过的地方不能再走,即要标记。

    判断时(下面的ok()函数),可以为0。

    我用scanf,printf,才对的,用cin,cout的话,即便加上ios::sync_with_stdio(0)也没对。

   

代码如下:

#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=100010;
int m[maxn];
int n,k;
struct node
{
    int pos,t;
};
int ok(int x)
{
    if(x>=0&&x<=maxn&&m[x]==0)//判断是否符合
        return 1;
    else
        return 0;
}
int ioan(int x)
{
    node p[maxn];
    node a,b;
    int head=0,tail=1;
    m[x]=1;
    a.pos=x;
    a.t=0;
    p[1]=a;
    do
    {
        head++;
        a=p[head];//出队
        if(a.pos==k)
        {
            return a.t;
        }
        b=a;
        b.pos=a.pos+1;
        if(ok(b.pos))
        {
            b.t=a.t+1;
            m[b.pos]=1;
            tail++;
            p[tail]=b;
        }
        b.pos=a.pos-1;
        if(ok(b.pos))
        {
            b.t=a.t+1;
            m[b.pos]=1;
            tail++;
            p[tail]=b;
        }
        b.pos=a.pos*2;
        if(ok(b.pos))
        {
            b.t=a.t+1;
            m[b.pos]=1;
            tail++;
            p[tail]=b;
        }
    }while(head<tail);
    return 0;
}

int main()
{

    while(~scanf("%d %d",&n,&k))
    {
        memset(m,0,sizeof(m));
        if(n==-1&&k==-1)
            break;
        int time=ioan(n);
        printf("%d\n",time);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值