Network Saboteur

Network Saboteur

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 27   Accepted Submission(s) : 11
Problem Description
A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
 

Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). <br>Output file must contain a single integer -- the maximum traffic between the subnetworks. <br>
 

Output
Output must contain a single integer -- the maximum traffic between the subnetworks.
 

Sample Input
  
  
3 0 50 30 50 0 40 30 40 0
 

Sample Output
  
  
90

    这题我开始还以为是个图问题,直接用了个floyd,没对,又重新看了题目,弄明白题意,是说给n个点和它们之间的距离,将这些点分成两个部分,每部分的距离为点之间的距离之和,求最大的距离。这是遇到第一个深搜,直接把所有情况试一下就行了。


#include <iostream>
#include <cstring>
const int MAXN=25;
using namespace std;
int c[MAXN][MAXN],vis[MAXN];
int maxn,n;
void ioan(int x,int sum)
{
    int temp=sum;   //未标记的和
    for(int i=1;i<=n;i++) //从1 到 n
    {
        if(vis[i]==0)// 0 加
            temp+=c[x][i];
        else
            temp-=c[x][i];// 1 减
    }
    if(maxn<temp)
    {
        maxn=temp;
    }
    for(int i=x+1;i<=n;i++)//从 x下一个 到n
    {
        if(temp>sum)
        {
            vis[i]=1;
            ioan(i,temp);
            vis[i]=0;//回溯
        }
    }
}
int main()
{
    while(cin>>n&&n)
    {
        maxn=0;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                cin>>c[i][j];
            }
        }
        vis[1]=1;
        ioan(1,0);
        cout<<maxn<<endl;
    }
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值