Pie 二分

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:<ul><li>One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.<li>One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.</ul>
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10<sup>3</sup>.
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
 

Source
PKU

      分饼的题,输入的时候先求个体积,然后二分就可以了。

      我十几分钟写出来,然后错了近十遍,白废了好久时间在上面,真是很无奈。

      说一下要注意的吧:PI要定义长一点,短了可能精度不够;判断(r-l)要小一点,不然精度不够,太小了可能超时,1e-6可以了。

      还有个想说的小问题,感觉四舍五入输出不该对的,应该要全都舍才对。打个比方,1块饼体积20,分给3个人的时候,每个人应该是6.666666...对吧,四舍五入的话输出6.6667。那这样三个人加起来就超过20了。当然这里是随便说说,这题是不管这些的,我说这个的意义在于我要说一个全都舍的方法:

   输出x,要求保留小数点后4位是,输出(x-0.00005)就可以了,4个0。保留几位几个0!!!当然用的是fixed<<setpresicion()输出。

代码如下:

#include<iostream>
#include<iomanip>
using namespace std;
const double PI=3.14159265358979;
double p[10010];
int main()
{
    int N,F,t;
    double r,sum;
    cin>>t;
    while(t--)
    {
        cin>>N>>F;
        sum=0;
        for(int i=1;i<=N;i++)
        {
            cin>>r;
            p[i]=PI*r*r;
            sum+=p[i];
        }
        sum=sum/F;
        double r,l,mid;
        l=0;
        r=sum;
        while((r-l)>1e-6)
        {
            mid=(l+r)/2;
            int x=0,y=0;
            for(int i=1;i<=N;i++)
            {
                y=(int)(p[i]/mid);
                x+=y;
            }
            if(x<F+1)
            {
                r=mid;
            }
            else if(x>=F+1)
            {
                l=mid;
            }
        }
        cout<<fixed<<setprecision(4)<<mid<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值