B - Pie ( HPU专题训练(6)二分)

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. 
InputOne line with a positive integer: the number of test cases. Then for each test case: 
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. 
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies. 
Output

   For each test case, output one line with the largest possible volume V such that me and my    friends can all get a pie piece of size V. The answer should be given as a floating point    number with an absolute error of at most 10^(-3).

Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

翻译:

我的生日快到了,传统上我是在做馅饼。不只是一个馅饼,不,我有一个数字N,各种口味和各种大小。我的朋友们都来参加我的聚会,每个人都分到一块馅饼。但是每个人分得的饼只能来自同一块饼,不能由多块饼拼凑。
我的朋友们都很讨厌,如果他们中的一个得到比其他人更大的一块,他们就开始抱怨。因此,他们所有人都应该得到同样大小的(但不一定是相同形状的)碎片,即使这会导致一些馅饼被破坏(这比破坏聚会好)。当然,我也想要一块馅饼,这一块也应该是同样大小的。
我们所有人能得到的最大的尺寸是多少?所有的馅饼都是圆柱形的,它们的高度都是一样的且都为1,但是馅饼的半径是不同的。
输入
一个带正整数的线:测试用例的数量。然后对每个测试用例:
---一行有两个整数N和F和1 <= N, F <= 10000:馅饼的数量和朋友的数量。
---一行有N个整数ri和1 <= ri <= 10000:派的半径。
输出
对于每个测试用例,输出一行,最大可能体积V,这样我和我的朋友们都能得到一块馅饼的大小诉答案应该是作为一个浮点数的绝对误差最多10 ^(3)。
样例输入
3
3个3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2。
样例输出
25.1327
3.1416

50.2655

题意:

N块馅饼分给F+1个人(包括主人),请问每个人分得的最大体积为多少?

思路:

因为存在多人共分一个馅饼的可能,以及部分馅饼可能丢弃等复杂情况,所以采用暴力破除的方法。遍历每个人可能分到的最小馅饼体积(left=0)以及最大馅饼体积(right=a[N-1](先将数组排序))。直接遍历由于时间复杂度高,是不可取的,所以应采用二分法求解。

#include<iostream>
#include<cmath>
#include<algorithm> 
using namespace std;
double pi=acos(-1.0);
int test(double mid,double a[],int N,int F)
{
	int sum=0;
	for(int i=0;i<N;i++)
	{
		sum+=int(a[i]/mid);//当前馅饼够几个人分。 
	}
	if(sum>=F)
	   return 1;
	return 0;   
}
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int N,F;
		cin>>N>>F,F++;
		double a[N];
		for(int i=0;i<N;i++)
		    cin>>a[i],a[i]=a[i]*a[i]*pi;    
		sort(a,a+N);
		double left=0,right=a[N-1];
		//每个人可能分到的最小馅饼体积 
		//以及最大馅饼体积 
		double mid;
		while(right-left>0.000001)//注意精度  
		{
			mid=(left+right)/2;
			if(test(mid,a,N,F))
			  left=mid;
			else
			  right=mid;  
		} 
		printf("%.4lf\n",mid);  
	}
} 


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值