Aggressive Cows

Problem Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
 

Input
* Line 1: Two space-separated integers: N and C <br> <br>* Lines 2..N+1: Line i+1 contains an integer stall location, xi
 

Output
* Line 1: One integer: the largest minimum distance
 

Sample Input
  
  
5 3 1 2 8 4 9
 

Sample Output
  
  
3
 
      这个小题我也是交了十多遍才出来的,要么错要么超时,实在崩溃!!!

      求最小值的最大值,二分特征很明显。

      开始想动态规划来着,递推公式都写好了(天知道我怎么写的),没有成功,还是乖乖二分吧。

      输入的是坐标,要排序后才能用!本来用了个数组有来存i和(i-1)的距离,画蛇添足,直接用坐标算的话很简单的。还有开始用的cin,改了scanf()。这俩肯定有一个是导致我超时的原因,具体哪个忘记了。其他的写法,这类问题挺公式化的一个东西,直接上吧。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<stdio.h>
using namespace std;
int main()
{
    int N,C;
    int pos[100010];
    int len[100010];
    int temp[100010];
    while(cin>>N>>C && (N+C))
    {
        memset(pos,0,sizeof(pos));
        memset(len,0,sizeof(len));
        memset(temp,0,sizeof(temp));
        for(int i=1;i<=N;i++)
            scanf("%d",&pos[i]);
        sort(pos,pos+N+1);
        int l=0;
        int r=pos[N];
        int mid=0;
        for(int i=1;i<=N;i++)
        {
            len[i]=pos[i]-pos[i-1];
        }
        while(l<r)
        {
            mid=(l+r)/2;
            int cnt=1;
            for(int i=2;i<=N;i++)
                temp[i]=len[i];
            for(int i=2;i<=N;i++)
            {
                if(temp[i]>=mid)
                {
                    cnt++;
                }
                else
                {
                    temp[i+1]+=temp[i];
                }
            }
            if(cnt>=C)
                l=mid+1;
            if(cnt<C)
                r=mid;
        }
        cout<<mid<<endl;
    }

    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值