U - Investigation

An integer is divisible by 3 if the sum of its digits is also divisible by 3. For example, 3702 is divisible by 3 and 12 (3+7+0+2) is also divisible by 3. This property also holds for the integer 9.

In this problem, we will investigate this property for other integers.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case contains three positive integers A, B and K (1 ≤ A ≤ B < 231 and 0 < K < 10000).

Output

For each case, output the case number and the number of integers in the range [A, B] which are divisible by K and the sum of its digits is also divisible by K.

Sample Input

3

1 20 1

1 20 2

1 1000 4

Sample Output

Case 1: 20

Case 2: 5

Case 3: 64


      求给定了一个K,求【a,b】内能够满足能被K整除并且每一位的和能被K整除的个数。特点是K是单给的,自己注意下就好了。写的dp数组,因为K的范围应该是定义到dp[20][10000][10000]的,很显然不成,交了几变小的试试不成,看人家题解,K过大的时候结果直接为0了,100左右的样子,应该没啥原因吧,用数学课本的一句话、可以证。

代码如下:

#include<iostream>
#include<cstring>
using namespace std;
typedef long long LL;
int t;
LL a, b, K;
int bit[20];
LL dp[20][100][100];
LL dfs(int pos, int mod, int sta, bool limit)
{
	if (pos == -1)
	{
		if (mod == 0 && sta == 0)
			return 1;
		return 0;
	}
	if (!limit && dp[pos][mod][sta] != -1)
		return dp[pos][mod][sta];
	int up = limit ? bit[pos] : 9;
	LL temp = 0;
	for (int i = 0; i <= up; i++)
	{
		int mod2 = (mod * 10 + i) % K;
		int sta2 = (sta + i) % K;
		temp += dfs(pos - 1, mod2, sta2, limit && i == up);
	}
	if (!limit)
		dp[pos][mod][sta] = temp;
	return temp;
}
LL solve(LL x)
{
	int pos = 0;
	while (x)
	{
		bit[pos++] = x % 10;
		x /= 10;
	}
	return dfs(pos - 1, 0, 0, 1);
}
int main()
{
	int cnt = 1;
	cin >> t;
	while (t--)
	{
		cin >> a >> b >> K;
		cout << "Case " << cnt++ << ": ";
		if (K >= 100)
		{
			cout << "0" << endl;
			continue;
		}
		memset(dp, -1, sizeof(dp));
		cout << solve(b) - solve(a - 1) << endl;
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值