2284: W-LINE

2284: W-LINE


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K221129Standard
There are n W-LINEs in the plane(see the picture). Now i want to ask what's the maximal possible areas can these W-LINEs separate the plane.Suppose the middle part of W-LINE is big enough and the two ends can extend infinete.

Input

The input contains several test cases. For each test case it contains a positive integer n (0 <= n <= 50). The end of input is indicated by end-of-file.

Ouput

For each test case, output K, here K is the maximal possible areas W-LINEs can separate the plane.

Sample Input

1
2
10

Sample Output

2
19
731

 

Problem Source: sharang

 


This problem is used for contest: 43  153 

 

 

#include<stdio.h>
int main()
{
    int i,n;
    int a[60]={1};
    a[1]=2;
    for(i=2;i<=55;i++) a[i]=a[i-1]+16*(i-1)+1;
    while(scanf("%d",&n)==1)
    {
        printf("%d/n",a[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值