2426: Minimize the number 删数问题

2426: Minimize the number


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
1s8192K1100153Standard

Give you a n-bit (decimal base) number, please remove k bits (decimal base) of the number to get the minimal number according to its original sequence.

Input

There are multiple test cases, first line of each test case is the n-bit number, the next line contains the number k(k <= n).

Output

Print out the minimal number in one line. Don't output the first zeros before the first none-zero number.

Sample Input

178543
2

Sample Output

1543

 

Problem Source: daoyuanlee

#include<iostream>
//#include<fstream.h>
#include<cmath>
#include<string.h>
using namespace std;
char a[10000];
int main()
{
    int i,j;
    int icount ,inum;
    while(cin>>a>>inum)
    {
    bool check=true;
    icount=strlen(a);
    j=0;
    for(i=1;i<icount;i++)
    {
        if(a[i]>=a[j])
        {
            j++;
            a[j]=a[i];
        }
        else
        {
            while((a[i]<a[j])&&j>=0&&inum>0)
            {
                j--;
                inum--;
            }
            j++;
            a[j]=a[i];
        }
    }
    if(inum>0)
    {
        j-=inum;
    }
    for(i=0;i<=j;i++)
    {
        if((a[i]=='0')&&check){}
        else
        {
            cout<<a[i];
            check=false;
        }
    }
    if(check)
    {
        cout<<'0';
    }
    cout<<endl;
    }
    return 0;
}

 

 

#include<iostream>
#include<string>
using namespace std;
int main()
{
    int n,i,j;
    string a;
    while(cin>>a>>n)
    {
        if(a.length()<=n) {printf("/n");continue;}
        while(n)
        {
            int flag=0;
            for(i=0;i<a.size();i++)
            {
                if(a[i]>a[i+1]||i==a.size()-1) {a.erase(a.begin()+i);flag=1;n--;break;}
            }
             if(!flag) { while(n--) {a.erase(a.end()-1);}break;}
            //cout<<a<<"   "<<n<<"   "<<a.length()<<endl;
        }
        for(i=0;i<a.size();i++)
        {
            if(a[i]!='0') break;
        }
        for(;i<a.size();i++) printf("%c",a[i]);
        printf("/n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值