2689 Prime Distance 素数筛选法, 筛选一段区间的素数

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4098 Accepted: 1097

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int is[50000],prime[50000];
int pl=0;
int ans[100010],flag[1000010];
int isprime(int x)
{
    double k=sqrt(0.0+x);
    for(int i=0;i<pl&&prime[i]<=k;i++)
    {
        if(x%prime[i]==0) return 0;
    }
    return 1;
}
int main()
{
    for(int i=2;i<50000;i++)
    {
        if(is[i]==0) prime[pl++]=i;//0表示素数
        for(int j=0;j<pl&&i*prime[j]<50000;j++)
        {
            is[i*prime[j]]=1;
            if(i%prime[j]==0) break;
        }
    }
    int s,t;
    while(scanf("%d%d",&s,&t)==2)
    {
        if(s>t) swap(s,t);
        if(s==1) s=2;
        int f=0;
        int num=0;
        int minl,minr,maxl,maxr;
        int minc=(1<<31)-1,maxn=(1<<31);
        if(t<50000)
        {
            for(int i=s;i<=t;i++)
            {
                if(is[i]==0) ans[num++]=i;
            }
        }
        else
        {
            memset(flag,0,sizeof(flag));//0表示素数
            int end=t-s;
          //  for(int i=s%2;i<=end;i++,i++)  flag[i]=1;
            for(int i=0;i<pl;i++)
            {
                int begin=s/prime[i]*prime[i];
                if(begin<s) begin+=prime[i];
                begin-=s;
                for(int j=begin;j<=end;j+=prime[i]) flag[j]=1;
            }
            for(int i=0;i<=end;i++)
            {
                if(flag[i]==0) ans[num++]=i+s;
            }
        }
        if(num<2) {printf("There are no adjacent primes./n");continue;}
        for(int i=1;i<num;i++)
        {
            if(ans[i]-ans[i-1]>maxn) maxn=ans[i]-ans[i-1],maxl=ans[i-1],maxr=ans[i];
            if(ans[i]-ans[i-1]<minc) minc=ans[i]-ans[i-1],minl=ans[i-1],minr=ans[i];
        }
        printf("%d,%d are closest, %d,%d are most distant./n",minl,minr,maxl,maxr);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值