1971 Parallelogram Counting 平面点集能组成多少个平行四边形 中点排序

这篇博客探讨了如何在给定一组平面点的情况下,通过中点排序算法来计算能够组成多少个不同的平行四边形。输入描述包括点的坐标,输出则展示了计算出的平行四边形数量。示例输入和输出提供了具体操作的实例。
摘要由CSDN通过智能技术生成
Parallelogram Counting
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3709 Accepted: 1149

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
bool equal(double x,double y)
{
    return fabs(x-y)<1e-4;
}
struct _Point
{
    double x,y;
};
_Point p[1100];
_Point a[1100*1100];
bool cmp(_Point h,_Point k)
{
    if(h.x!=k.x) return h.x<k.x;
    return h.y<k.y;
}
int main()
{
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        int n;scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        int pl=0;
        for(int i=0;i<n;i++) for(int j=i+1;j<n;j++) a[pl].x=(p[i].x+p[j].x)/2,a[pl++].y=(p[i].y+p[j].y)/2;
        //对于一个平行四边形,其两条对角线的的交点是其中点。因此可以计算每条线段的中点是否相等判断是否相等
        sort(a,a+pl,cmp);//中点排序
        long long cnt=0,t=0;
        for(int i=0;i<pl;i++)
        {
            if(i&&!(equal(a[i].x,a[i-1].x)&&equal(a[i].y,a[i-1].y)))
            {
                cnt+=t*(t-1)/2;
                t=1;
            }
            else t++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值