2155 Matrix 二维线段树 将一段区间取反,问某一位置的值

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 7710 Accepted: 2891

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
#include <stdio.h>
#include <string.h>
bool a[3000][3000];
int n, sum;
/*
* 修改过程:
* 以x为主轴, y为次轴建立二维线段树. 先从x周开始找到线段[x1, x2]对应的节点rootx,
* 之后按照y轴找到线段[y1, y2]对应的节点rooty, 将元素a[rootx][rooty]取反.
*/
void Modify_y(int rootx, int rooty, int first, int last, int y1, int y2)
//rootx是外层线段树节点
//rooty是内层线段树节点
//first ,last 是内层线段树左右端点
//y1,y2是要修改的内维范围
{
//rootx外层节点包含的内层线段树的rooty节点所对应的矩形区域,是否完整被改过就记在a[rootx][rooty]
    if (y1 == first && last== y2)
        a[rootx][rooty] = !a[rootx][rooty];
    else     {
        int mid = (first+last)/2;
        if (y2 <= mid)
            Modify_y(rootx, (rooty<<1)+1, first, mid, y1, y2);
        else if (y1 > mid)
            Modify_y(rootx, (rooty<<1)+2, mid+1, last, y1, y2);
        else{
            Modify_y(rootx, (rooty<<1)+1, first, mid, y1, mid);
            Modify_y(rootx, (rooty<<1)+2, mid+1, last, mid+1, y2);
        }
    }
}
void Modify_x(int root, int first, int last, int x1, int x2, int y1, int y2)
//root 是外维线段树节点
//first ,last 是该节点的左右端点
//x1,x2,y1,y2是要修改的矩形坐标
{
    if (x1 == first && last == x2)
        Modify_y(root, 0, 1, n, y1, y2); //0是当前外层节点包含的内层线段树的根节点
    else {
        int mid = (first+last)/2;
        if (x2 <= mid)
            Modify_x((root<<1)+1, first, mid, x1, x2, y1, y2);
        else if (x1 > mid)
            Modify_x((root<<1)+2, mid+1, last, x1, x2, y1, y2);
        else{
            Modify_x((root<<1)+1, first, mid, x1, mid, y1, y2);
            Modify_x((root<<1)+2, mid+1, last, mid+1, x2, y1, y2);
        }
    }
}
/*
* 查询过程:
* 首先明确一点, 一维情况下, 查找单个点时, 找到路径上一定会遍历所有包含该点的线段.
* 那么在二维情况下, 查找一个点就需要遍历所有包含该点的矩形.
*/
void Query_y(int rootx, int rooty, int first, int last, int y)
{
    sum ^= a[rootx][rooty];
    if (first < last)
    {
        int mid = (first+last)/2;
        if (y <= mid)
            Query_y(rootx, (rooty<<1)+1, first, mid, y);
        else
            Query_y(rootx, (rooty<<1)+2, mid+1, last, y);
    }
}
void Query_x(int root, int first, int last, int x, int y)
//root是外层线段树的节点
//first,last是该节点的左右端点
//x是外维的坐标
//y是内维的坐标
//查询的结果是坐标为(x,y)的元素的值,放在sum里面
{
    Query_y(root, 0, 1, n, y);
    if (first < last)
    {
        int mid = (first+last)/2;
        if (x <= mid)
            Query_x((root<<1)+1, first, mid, x, y);
        else
            Query_x((root<<1)+2, mid+1, last, x, y);
    }
}
int main()
{
    int cases, t, x1, y1, x2, y2;
    char op;
    scanf("%d", &cases);
    int pl=0;
    while (cases--)
    {
        if(pl==0) pl++;else printf("/n");
        scanf("%d%d", &n, &t);
        memset(a, 0, sizeof(a));
        while (t--)
        {
            scanf("%*c%c", &op);
            if (op == 'C')
            {
                scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                Modify_x(0, 1, n, x1, x2, y1, y2);
            }
            else{
                scanf("%d%d", &x1, &y1);
                sum = 0;
                Query_x(0, 1, n, x1, y1);
                printf("%d/n", sum);
            }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值