2773 Happy 2006 输入m和k,让你求从小到大排列,第k个与m互素的正整数

Happy 2006
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5108 Accepted: 1514

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
#include<iostream>
#include<cstdio>
using namespace std;
__int64 gcd(__int64 a,__int64 b)
{
    return b==0?a:gcd(b,a%b);
}
__int64 a[1000001];
int main()
{
    __int64 n,k;
    while(scanf("%I64d%I64d",&n,&k)==2)
    {
        __int64 pl=0;
        int flag=1;
        for(__int64 i=1;i<=n;i++)
        {
            if(gcd(i,n)==1)
            {
                a[pl++]=i;
                if(pl==k)//如果在(1,n)中
                {
                    printf("%I64d/n",i);
                    flag=0;
                    break;
                }
            }
        }
        //如果大于n,设为num=x*n+y;(x=num/n,y=num%n)
        //gcd(a,b)=gcd(b,a%b)可得:gcd(num,n)=gcd(n,y);
        //所以若gcd(l,n)==1,则l定能写成l=x*n+y形式
        if(flag)
        {
            __int64 p=k/pl;
            int t;
            if(k%pl) t=k%pl;
            else t=pl,p--;//如果k是pl的倍数,单独考虑
            __int64 cnt=a[t-1]+n*p;
            printf("%I64d/n",cnt);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值