2992 Divisors 求C(N,K)的因子个数

Divisors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6785 Accepted: 1781

Description

Your task in this problem is to determine the number of divisors of Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of Cnk. For the input instances, this number does not exceed 2 63 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16
n!的素因子i的个数 = (n-1)!的素因子i的个数 + n的素因子i的个数
c(n,k)的素因子i的个数 = n!的素因子i的个数- (n-k)!的素因子i的个数 - k!的素因子i的个数
#include<iostream>
#include<cstdio>
using namespace std;
int is[500],prime[500],pl;
void _prime()
{
    for(int i=2;i<500;i++)
    {
        if(is[i]==0) prime[pl++]=i;
        for(int j=0;j<pl&&i*prime[j]<500;j++)
        {
            is[i*prime[j]]=1;
            if(i%prime[j]==0) break;
        }
    }
}
__int64 _count(int n,int p)
{
    __int64 cnt=0;
    while(n)
    {
        cnt+=n/p;
        n/=p;
    }
    return cnt;
}
int main()
{
    _prime();
    int n,k;
    while(scanf("%d%d",&n,&k)==2)
    {
        __int64 cnt=1;
        for(int i=0;prime[i]<=n;i++)
        {
            cnt*=(1+_count(n,prime[i])-_count(k,prime[i])-_count(n-k,prime[i]));
        }
        printf("%I64d/n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值