hdu 3501 Calculation 2 求所以小于n且与n不互质的数之和

Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
0 2

//


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
//phi(n)*n/2求得所以小于n且与n互质的数之和,
//再用所有小于n的和减去它就为结果。
const int maxn=110000;
int flag[maxn],pri[maxn],pl;
void _prime()
{
    for(int i=2;i<maxn;i++)
    {
        if(flag[i]==0) pri[pl++]=i;
        for(int j=0;j<pl&&i*pri[j]<maxn;j++)
        {
            flag[i*pri[j]]=1;
            if(i%pri[j]==0) break;
        }
    }
}
int phi(int n)
{
    int ans=n;
    for(int i=0;i<pl&&pri[i]*pri[i]<=n;i++)
    {
        if(n%pri[i]==0)
        {
            ans-=ans/pri[i];
            while(n%pri[i]==0) n/=pri[i];
        }
    }
    if(n>1) ans-=ans/n;
    return ans;
}
int main()
{
    _prime();
    int n;
    int mod=1000000007;
    while(scanf("%d",&n)==1&&n)
    {
        int tmp=((long long)n*(n-1)/2)%mod;
        int sf=((long long)phi(n)*n/2)%mod;
        int ans=tmp-sf;
        printf("%d\n",(ans%mod+mod)%mod);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值