PAT (Advanced Level)1028. List Sorting (25)

题目链接

1028. List Sorting (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

//1028. List Sorting(25)

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

struct student {
	int ID;
	char name[20];
	int sco;
};

bool cmp1(student a, student b) {
	return a.ID < b.ID;
}
bool cmp2(student a, student b) {
	if (strcmp(a.name, b.name) != 0)
		return strcmp(a.name, b.name) < 0;
	else return a.ID < b.ID;
}
bool cmp3(student a, student b) {
	if (a.sco != b.sco)
		return a.sco < b.sco;
	else return a.ID < b.ID;
}

int main() {
	int m, n;
	while (cin >> m >> n) {
		vector<student>s(m);
		for (int i = 0; i < m; i++) {
			scanf("%d%s%d", &s[i].ID, s[i].name, &s[i].sco);
		}
		if (n == 1)
			sort(s.begin(), s.end(), cmp1);
		else if (n == 2)
			sort(s.begin(), s.end(), cmp2);
		else if (n == 3)
			sort(s.begin(), s.end(), cmp3);
		for (int i = 0; i < m; i++) {
			printf("%06d %s %d\n", s[i].ID, s[i].name, s[i].sco);
		}
	}
	return 0;
}

ps:回学校啦

ps:C++中#include<string>、#include<string.h>、#include<cstring>头文件是不一样的,开始只加入了头文件#include<string>,运用strcmp()函数,本地测试样例运行丝毫无问题,提交后总是编译出错,在这里浪费了好多时间。

        注意:string头文件是用来定义字符串的,例如string s; ;而string.h和cstring是char用的,使用strcmp()、strcpy()函数等。

ps:使用cin>>和cout<<竟然会有超时错误,第一次见,尽量使用scanf和printf,scanf输入时对于char[]类型不需要加“&”

ps:简单题,因为知识盲点浪费了好多时间

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值