PAT (Advanced Level)1117. Eddington Number(25)

1117. Eddington Number(25)

时间限制
250 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:
6

耗时10分钟左右

这道题正确率0.24???真的怪,为什么我费那么大劲弄懂得题正确率都超高,这道题这么简单竟然疑问疑问

题意理解有点费劲,大意是:给一组数,找出其中比X大的数且其在这组数中的数量>=X,输出满足题意的X的最大值。记得考虑这组数全为零的情形。


//Mar12_No5_PATAL1118

#include <iostream>
using namespace std;

int main() {
	int n, cnt, count, a[100001];
	cin >> n;
	for (int i = 0; i < n; i++) 
		cin >> a[i];
	for (int i = 0; i <=n; i++) {
		cnt = n - i;
		count = n;
		for (int j = 0; j < n; j++) 
			if (a[j] <= cnt) 
				count--;
		if (count >= cnt) {
			cout << cnt << endl;
			break;
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值