PAT (Advanced Level)1030. Travel Plan (30) dfs

题目链接

1030. Travel Plan (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40
代码来源此处
#include<cstdio>  
#include<string>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
using namespace std;

const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 5e2 + 10;
int n, m, s, t, map[maxn][maxn], cost[maxn][maxn], x, y, z, c;
int dis[maxn], v[maxn];

void dfs(int x)
{
	if (x == t) return;
	for (int i = 0; i < n; i++)
	{
		if (map[x][i])
		{
			if (dis[i]>dis[x] + map[x][i])
			{
				dis[i] = dis[x] + map[x][i];
				v[i] = v[x] + cost[x][i];
				dfs(i);
			}
			else if (dis[i] == dis[x] + map[x][i] && v[i] > v[x] + cost[x][i])
			{
				v[i] = v[x] + cost[x][i];
				dfs(i);
			}
		}
	}
}

bool Dfs(int x)
{
	if (x == s) { printf("%d ", s); return true; }
	for (int i = 0; i < n; i++)
	{
		if (map[x][i] && dis[x] == dis[i] + map[x][i] && v[x] == v[i] + cost[x][i])
		{
			if (Dfs(i)) { printf("%d ", x); return true; }
		}
	}
	return false;
}

int main()
{
	scanf("%d%d%d%d", &n, &m, &s, &t);
	while (m--)
	{
		scanf("%d%d%d%d", &x, &y, &z, &c);
		if (!map[x][y] || map[x][y] > z)
		{
			map[x][y] = map[y][x] = z;
			cost[x][y] = cost[y][x] = c;
		}
		else if (map[x][y] == z) cost[x][y] = cost[y][x] = min(c, cost[x][y]);
	}
	for (int i = 0; i < n; i++) dis[i] = v[i] = INF;
	dis[s] = v[s] = 0;
	dfs(s);
	Dfs(t);//逆向递归输出
	printf("%d %d\n", dis[t], v[t]);
	return 0;
}

开始用迪杰斯特拉做不出来,真是菜。

ps:考研一志愿录取失败

travel Algrithm. #include <stdio.h> #include <stdlib.h> #include <string.h> #include <malloc.h> #include <conio.h> struct Path { char pass[25]; //sign passed note. int min_distance; //minmax distance from concurrent note.// int nextcity; //next note from current note. struct Path *next; }; int C[25][25]; int Getmin(struct Path *G[25][25],int i,int num_S,char S[25]); // search G[i][n] linking-node. void Write(int i,int n,char S[25],struct Path *G[25][25],int num_S); // Calculate G[i][num_S] void Travel(int size,int i,int n,char S[25],struct Path *G[25][25],int num_S); // signed V-S node. void Trip(int n,char S[25],struct Path *G[25][25]); // Calculate and output the min_distance. void Printpath(char S[],int path[],struct Path *G[][25],int n); // print the path // S[] is the charater of the node. void main() { int n,i,j; int output[25]; char S[25]; struct Path *G[25][25]; printf("Please enter the number of cities:\n"); // Input the numbers of node scanf("%d",&n); printf("Please enter the matrix:\n"); // Input the maxtric of weight. for(i=0;i<n;i++) for(j=0;j<n;j++) scanf("%d",&C[i][j]); printf("The number of cities is:%d\n",n); for(i=0;i<n;i++) { for(j=0;j<n;j++) printf("%d\t",C[i][j]); printf("\n"); } for(i=0;i<n;i++) S[i]='0'; S[i]='\0'; for(i=0;i<n;i++) { G[i][0]=(struct Path *)malloc(sizeof(struct Path)); strcpy(G[i][0]->pass,S); G[i][0]->min_distance=C[i][0]; G[i][0]->next=NULL; } for(i=0;i<n;i++) for(j=1;j<n;j++) G[i][j]=NULL; Trip(n,S,G); Printpath(S,output,G,n); printf("For the demonstration route:\n"); for(i=0;i<n;i++) printf("%d->",output[i]+1); printf("1\n"); getch(); }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值