1143. Lowest Common Ancestor (30)

1143. Lowest Common Ancestor (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

使用的cin,cout有一个点超时了

#include <iostream>
#include <set>
using namespace std;
int m, n, a, b, pre[10001];
set<int>s;
int find_border(int r, int l) {
  int i;
  for (i = l + 1; i < m&&pre[i] < pre[l]; i++);
  return i;
}
int find_ance(int l, int r) {
  if (a > pre[l] && b > pre[l]) find_ance(find_border(pre[l], l), r);
  else if (a < pre[l] && b < pre[l]) find_ance(l + 1, find_border(pre[l], l) - 1);
  else return pre[l];
}
int main() {
  cin >> m >> n;
  for (int i = 0; i < n; i++) {
    cin >> pre[i];
    s.insert(pre[i]);
  }
  for (int i = 0; i < m; i++) {
    cin >> a >> b;
    if (s.find(a) == s.end() && s.find(b) == s.end())
      cout << "ERROR: " << a << " and " << b << " are not found." << endl;
    else if (s.find(a) != s.end() && s.find(b) == s.end())
      cout << "ERROR: " << b << " is not found." << endl;
    else if (s.find(a) == s.end() && s.find(b) != s.end())
      cout << "ERROR: " << a << " is not found." << endl;
    else { int ance = find_ance(0, n - 1); 
    if (ance == a) cout << ance<<" is an ancestor of "<<b<<"." << endl;
    else if(ance==b) cout << ance << " is an ancestor of " << a << "." << endl;
    else cout << "LCA of " << a << " and " << b << " is " << ance << "." << endl;
    }
  }
  system("pause");
  return 0;
}

改成scanf,printf刚才超时的点竟也199ms了

#pragma warning(disable:4996)
#include <iostream>
#include <set>
using namespace std;
int m, n, a, b, pre[10001];
set<int>s;
int find_border(int r, int l) {
  int i;
  for (i = l + 1; i < m&&pre[i] < pre[l]; i++);
  return i;
}
int find_ance(int l, int r) {
  if (a > pre[l] && b > pre[l]) find_ance(find_border(pre[l], l), r);
  else if (a < pre[l] && b < pre[l]) find_ance(l + 1, find_border(pre[l], l) - 1);
  else return pre[l];
}
int main() {
  scanf("%d %d", &m, &n);
  for (int i = 0; i < n; i++) {
    scanf("%d", &pre[i]);
    s.insert(pre[i]);
  }
  for (int i = 0; i < m; i++) {
    scanf("%d %d", &a, &b);
    if (s.find(a) == s.end() && s.find(b) == s.end())
      printf("ERROR: %d and %d are not found.\n", a, b);
    else if (s.find(a) != s.end() && s.find(b) == s.end())
      printf("ERROR: %d is not found.\n", b);
    else if (s.find(a) == s.end() && s.find(b) != s.end())
      printf("ERROR: %d is not found.\n", a);
    else { int ance = find_ance(0, n - 1); 
    if (ance == a)  printf("%d is an ancestor of %d.\n", a, b);
    else if(ance==b)  printf("%d is an ancestor of %d.\n", b, a);
    else  printf("LCA of %d and %d is %d.\n", a, b, ance);
    }
  }
  system("pause");
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值