1102. Invert a Binary Tree (25)

1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

官方通过率60多的一道题,我不会

现在就是一遇到树图的题不管难不难心里自动就打起了退堂鼓,加上不会的题本身就不爱做,所以这道题我想一会玩会手机、出去晒晒太阳,最后,临摹着别人的代码,2个小时左右弄完了。好丧好丧。。。。。


//1102
#include <iostream>
#include <queue>
#include <string>
#include <vector>
using namespace std;
struct node {
	int lchild, rchild, parent;
	node():lchild(-1),rchild(-1),parent(-1){}
}no[10];
int findRoot(int t) {
	if (no[t].parent != -1)
		return findRoot(no[t].parent);
	return t;
}
vector<int>res;
void levelOrder(int r) {
	queue<int>q;
	q.push(r);
	while (!q.empty()) {
		int cur = q.front();
		res.push_back(cur);
		q.pop();
		if (no[cur].rchild != -1) q.push(no[cur].rchild);
		if(no[cur].lchild != -1) q.push(no[cur].lchild);
	}
}
void inOrder(int r) {
	if (no[r].rchild != -1) inOrder(no[r].rchild);
	res.push_back(r);
	if (no[r].lchild != -1) inOrder(no[r].lchild);
}
void print(vector<int> vx) {
	for (int i = 0; i < vx.size(); ++i) {
		if (i) cout << " " << vx[i];
		else cout << vx[i];
	}
	cout << endl;
}
int main() {
	int n;
	cin >> n;
	for (int i = 0; i < n; i++) {
		string l, r;
		cin >> l >> r;
		if (l != "-") {
			no[i].lchild = atoi(l.c_str());
			no[atoi(l.c_str())].parent = i;
		}
		if (r != "-") {
			no[i].rchild = atoi(r.c_str());
			no[atoi(r.c_str())].parent = i;
		}
	}
	int root = findRoot(0);
	res.clear();
	levelOrder(root);
	print(res);
	res.clear();
	inOrder(root);
	print(res);
	system("pause");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值