PAT-A1102 Invert a Binary Tree 题目内容及题解

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目大意

题目给定一个二叉树,要求将其翻转并将翻转后的二叉树的层次遍历和中序遍历输出。

解题思路

  1. 读入二叉树;
  2. 用先右后左的方式获得层序遍历并输出;
  3. 用先右后左的方式获得中序遍历并输出;
  4. 返回零值。

代码

#include<stdio.h>

struct Node{
    int lchild,rchild;
}node[15];

int N,root,HashTable[15];

void Init(){
    int i;
    char a,b;
    scanf("%d",&N);
    getchar();
    for(i=0;i<N;i++){
        scanf("%c %c",&a,&b);
        getchar();
        if(a=='-'){
            node[i].lchild=-1;
        }else{
            node[i].lchild=a-'0';
            HashTable[a-'0']=1;
        }
        if(b=='-'){
            node[i].rchild=-1;
        }else{
            node[i].rchild=b-'0';
            HashTable[b-'0']=1;
        }
    }
    for(i=0;i<N;i++){
        if(HashTable[i]==0){
            root=i;
            break;
        }
    }
}

void LayerOrder(){
    int Queue[15],rear=0,front=0;
    int top,num=N;
    Queue[rear++]=root;
    while(rear>front){
        top=Queue[front++];
        printf("%d",top);
        if(--num){
            printf(" ");
        }
        if(node[top].rchild!=-1){
            Queue[rear++]=node[top].rchild;
        }
        if(node[top].lchild!=-1){
            Queue[rear++]=node[top].lchild;
        }
    }
    printf("\n");
}

void InOrder(int r){
    if(r==-1){
        return;
    }
    InOrder(node[r].rchild);
    printf("%d",r);
    if(--N){
        printf(" ");
    }
    InOrder(node[r].lchild);
}

int main(){
    Init();
    LayerOrder();
    InOrder(root);
    printf("\n");
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值