2016多校8 hdu5821 Ball 智商题

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 735    Accepted Submission(s): 432


Problem Description
ZZX has a sequence of boxes numbered  1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For  1in , if the  i -th box is empty then  a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
 

Author
学军中学

这种题怎么分类。。。完全是看人脑子转不转得过来啊。。。

在在b[]中寻找a[]中的球的位置,将这个位置信息标志给a[]。

比如a{1,0,1,0,1},b{1,1,1,0,0}这样的,经过处理后应该变为{1,4,2,5,3}

每次题中给的区间其实就是对这个区间排序,若要想让a变成b的样子,那么经过题中排序后a数组中应该是顺序排列的。。。

奶奶的,谁想出来的

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
using namespace std;
const int maxn = 1005;
int a[maxn];
int b[maxn];
int main(){
    int t,n,m,i,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(i=1;i<=n;i++){
            scanf("%d",&b[i]);
        }
        bool flag=true;
        for(i=1;i<=n;i++){
            bool find=false;
            for(j=1;j<=n;j++){
                if(a[i]==b[j]){
                    a[i]=j;
                    b[j]=-1;
                    find=true;
                    break;
                }
            }
            if(!find){
                flag=false;
                break;
            }
        }

        int l,r;
        for(i=1;i<=m;i++){
            scanf("%d%d",&l,&r);
            sort(a+min(l,r), a+max(r,l)+1);
        }
        if(!flag){
            printf("No\n");
            continue;
        }
        flag=true;
        for(i=1;i<=n;i++){
            if(a[i]!=i){
                flag=false;
                break;
            }
        }
        if(flag){
            printf("Yes\n");
        }else{
            printf("No\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值