HDU - 3342 Legal or not(拓扑排序判断成环)

点击打开题目链接

Legal or Not
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 8213 Accepted Submission(s): 3862

Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s Prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output “YES”, otherwise “NO”.

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

Author
QiuQiu@NJFU

Source
HDOJ Monthly Contest – 2010.03.06

Submit

题目大意:判断是否成环。
思路:in_degree数组记录入度,将入度为0的点存入队列,删去该点出边,统计入度为0的点是否最终等于n。WA了一次,发现没有判断重边的情况。
附上AC代码:

#include<iostream>
#include<queue>
#include<cstring>

using namespace std;
const int maxn=100+5;
int in_degree[maxn];
int G[maxn][maxn];
int n,m;
int mas,pre;
queue<int>q;

void init()
{
    for(int i=0;i<=n;i++)
        in_degree[i]=0;
    memset(G,0,sizeof(G));
    while(!q.empty())q.pop();
}

int toposort()
{
    int num=0;
    for(int i=0;i<n;i++)
        if(in_degree[i]==0)
            q.push(i);
    while(!q.empty())
    {
        int temp=q.front();
        q.pop();
        num++;
        for(int i=0;i<n;i++)
        {
            if(G[temp][i]>0)
            {
                in_degree[i]--;
                if(in_degree[i]==0)
                q.push(i);
            }
        }
    }
    if(num==n)return 1;
    return 0;
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m,n)
    {
        init();
        for(int i=0;i<m;i++)
        {
            cin>>mas>>pre;
            if(G[mas][pre]==0)
            {
                G[mas][pre]=1;
                in_degree[pre]++;
            }
        }
        if(toposort())cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值