POJ - 3255 Roadblocks(Dijkstra求次短路)

点击打开题目链接

Roadblocks
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 14531Accepted: 5107

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers:  N and  R 
Lines 2.. R+1: Each line contains three space-separated integers:  AB, and  D that describe a road that connects intersections  A and  B and has length  D (1 ≤  D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node  N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:求起点到终点的次短路长度。

思路:dijkstra算法。数组同时保存最短路和次短路,判断时除去判断是否路径权值小于当前最短路外还要判断是否大于最短路且小于当前次短路

附上AC代码:

#include<iostream>
#include<queue>
#include<algorithm>
#include<vector>

using namespace std;
const int maxn = 5000 + 5;
const int Inf = 0x7f7f7f;
int dis[maxn];//最短路径
int dis2[maxn];//次短路径
typedef pair<int, int>P;//first=最短路,second=路口标号
int n, r;

struct edge {
	int to, dis;
};

vector<edge>G[maxn];

void dijkstra()
{
	priority_queue<P, vector<P>, greater<P> >pq;
	fill(dis + 1, dis + 1 + n, Inf);
	fill(dis2 + 1, dis2 + 1 + n, Inf);
	dis[1] = 0;
	pq.push(P(0, 1));
	while (!pq.empty())
	{
		P p = pq.top();
		pq.pop();
		int v = p.second, d = p.first;
		if (dis2[v] < d)continue;//当前次短路径小于标记的最短路径,已经扫描过
		for (int i = 0; i < G[v].size(); i++)
		{
			edge e = G[v][i];
			int d2 = d + e.dis;
			if (dis[e.to] > d2) {
				swap(dis[e.to], d2);
				pq.push(P(dis[e.to], e.to));
			}
			if (dis[e.to] < d2 && dis2[e.to] > d2) {
				dis2[e.to] = d2;
				pq.push(P(dis2[e.to], e.to));
			}

		}
	}
	cout << dis2[n] << endl;
}

int main()
{
	ios::sync_with_stdio(false);
	cin >> n >> r;
	for (int i = 0; i < r; i++)
	{
		edge e;
		int from;
		cin >> from >> e.to >> e.dis;
		G[from].push_back(e);
		swap(from, e.to);
		G[from].push_back(e);
	}
	dijkstra();
//	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值