HDU - 1452 Happy 2004 (求因子和)

Happy 2004

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2032    Accepted Submission(s): 1482


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, in a separate line, please output the result of S modulo 29.
 

Sample Input
 
 
1 10000 0
 

Sample Output
 
 
6 10
 

Source


思路:

2004  = 2^2+3^1+167^1;

因为要对29取余  167 和 22 对29同余。

由公式:

    g(p, e) = (p^(e+1) - 1) / (p-1),s(n) = g(p1, e1) * g(p2, e2) * ... * g(pk, ek)。

因为   (p^(e+1)-1)/(p-1)的溢出情况,我们把除法改为乘以其逆元



#include<bits/stdc++.h>
#define LL long long
using namespace std;

const int MAX = 1e6+10;
const int INF = 0x3fffffff;

int qpow(int a,int b){
    int r=1,base=a;
    while(b){
        if(b&1){
            r=r*base%29;
        }
        base=base*base%29;
        b>>=1;
    }
    return r%29;
}
int main(){
    int x;
    while(scanf("%d",&x)!=EOF&&x){
        int a=(qpow(2,2*x+1)-1)%29 ;
        int b=(qpow(3,x+1)-1)*(-14)%29 ;
        int c=(qpow(22,x+1)-1)*(-11)%29 ;
        printf("%d\n",a*b*c%29) ;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值