Wooden Sticks

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22332    Accepted Submission(s): 8992


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source
思路:用结构体存储其l和w,然后对l由小到大排序。如测试数据 6       4 9 5 2 2 1 3 5 1 4 5 7 来说:前者为 L,后者为 W,对 L 结构体二重排序,得到 L 是有序的,W无序,即(L , W) (1,4)(2,1)(3,5)(4,9)(5,2)(7,1),再比较前后两个的 W。如 1<4,  1就不在以4为起点的链条内,5>=4 , 5在以4为起点的链条内,9>=4, 9在以4为起点的链条内。。。。最后以W=4为起点的链条内的有(1,4)( 3, 5) ( 4, 9)...在以W=1为起点的链条内的有(2,1)(5,2)...以W=7为起点的链条内的有(7,1)。有三条链,于是sum=3。

#include<stdio.h>
#include<algorithm>


using namespace std;

struct Node{
	int x;
	int y;
}node[5001];
int cmp(Node a,Node b){
	if(a.x==b.x)
	return a.y<b.y;
	else return a.x<b.x;
	
}
int main(){
	
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		
		for(int i=0;i<n;i++)
		scanf("%d%d",&node[i].x,&node[i].y);
		
		
		sort(node,node+n,cmp);
		
		int sum=0;
		int sss;
		for(int i=0;i<n;i++)
		{
			
		
			if(node[i].x!=0){
			sum++;
			sss=node[i].y;
			
			for(int j=i+1;j<n;j++)
			{
				if(node[j].x!=0&&sss<=node[j].y){
					sss=node[j].y;
				
					node[j].x=0;
					
				}
				
			}
			}
			
		}

		printf("%d\n",sum);
		
	}
	
	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值