Radar

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
来源
Beijing 2002
上传者

ctest

思路:以每一个岛屿为圆心,雷达半径作为半径画一个圆必定与x轴相交(如果不相交就直接输出-1),那么会产生两个交点,我们就把这两个端点看做是这个区间的端点。然后转化为区间选点问题。


 
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;

struct Node{
	double x;
	double y;
}node[1002];
 //按照区间的右端点从小到大排序,如果右端点相等,那么按照左端点从大到小排序  
bool cmp(Node a,Node b){
	if(a.y!=b.y)
	return a.y<b.y;
	else return a.x>b.x;
}

int main(){
	
	int n,r;
	int Case=1;
	while(scanf("%d%d",&n,&r)!=EOF){
		if(n==0&&r==0)
		break;
		
		memset(node,0,sizeof(node));
		
		int flag=0;
		for(int i=0;i<n;i++)
		{
			double x,y;
			scanf("%lf%lf",&x,&y);
			if(y>r)
			flag=1;
			
			double  len=sqrt(1.0*r*r-1.0*y*y);//**结合图形,勾股定理**//  
            node[i].x=x-len;//**左交点的坐标**//  
           node[i].y=x+len;//**右交点的坐标**/
		}
		
		if(flag)
		{
			printf("Case %d: -1\n",Case++);
			continue;
		}	
		sort(node,node+n,cmp);
		
		int sum=1;
		
		double st=node[0].y;
		
		for(int i=1;i<n;i++)
		{
			if(st<node[i].x)//如果后一个点的左交点大于前一个点的右坐标,说明两点没有公共区域,sum++
			{
				sum++;
				st=node[i].y;
			}
			
		}
		
		printf("Case %d: %d\n",Case++,sum);
	}
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值