HDU2005:第几天?

点击打开题目链接

第几天?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54250    Accepted Submission(s): 20492


Problem Description
给定一个日期,输出这个日期是该年的第几天。
 

Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。
 

Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
 

Sample Input
      
      
1985/1/20 2006/3/12
 

Sample Output
      
      
20 71
 

Author
lcy
 

Source
 

Recommend
JGShining
 


=====================================[ 代码 ]=====================================


#include <cstdio>

using namespace std;

#define IsLeapYear( year ) ( ( year % 400 == 0 ) || ( year % 4 == 0 && year % 100 != 0 ) )

const int kDaysOfMouse[ 12 ] = { 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 };
const int kDaysBeforeMouse[ 12 ] = { 0, 31, 59, 90, 120, 151, 181, 212, 243, 273, 304, 334 };

void PrintDaysBeforeMouse()
{
    for( int i = 0, days = 0 ; i < 12 ; ++i )
    {
        printf( "%d%s", days, ( i == 11 ? "\n" : ", " ) );
        days += kDaysOfMouse[ i ];
    }
}

int main()
{
    int year, mouth, day;
    while( scanf( "%d/%d/%d", &year, &mouth, &day ) == 3 )
    {
        int index = kDaysBeforeMouse[ mouth - 1 ] + day;
        if( IsLeapYear( year ) && mouth > 2 ) { ++index; }
        printf( "%d\n", index );
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值