HDOJ 2058 The sum problem(数学求和问题)

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8287    Accepted Submission(s): 2530


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
  
  
20 10 50 30 0 0
 

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 


首先想到的是暴力求解


#include<stdio.h>
int main()
{
    long i,j,d,sum,k,n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)   break;
        for (i=1;i<=n;i++)
       {
       sum=0;
       k=i;
         for(j=i;j<=n;j++)
         {
             sum+=j;
             if(sum==m)
             {
                     printf("[%d,%d]\n",k,j);
                     break;
             }
             if(sum>m) break;
         }
       }
       printf("\n");
    } 
    return 0;
}
果然超时.


然后想到高斯求和,分别以s和e表示,由等差数列求和公式有(s+e)*(e-s+1)/2==M(1式),化为e*(e+1)-s*(s-1)==2*M, so , e=(int)sqrt(2*M+s*(s-1)),将得到的e再代回1式,成立则[s,e]满足条件。

但是,2*M+s*(s-1)太大……

后来参考网上的一个算法,不考虑子列的终点,而是考虑子列的起点和子列元素的个数,分别记为i,j。由等差数列求和公式,得(i+(i+j-1))*j/2==M ,即(2*i+j-1)*j/2==M(2式),故得i=(2*M/j-j+1)/2,将i,j代回2式,成立则[i,i+j-1]满足条件。注意j最小为1,而由2式,得(j+2*i)*j=2*M,而i>=1,故j*j<=(int)sqrt(2*M).

#include <stdio.h>
#include <math.h>
int main()
{
    int i,j,n,m,t;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=(int)sqrt(2.0*m);j++)
            {
                if(j*(2*i+j-1)==2*m) printf("[%d,%d]\n",i,i+j-1);
            }
        }
        printf("\n");
    }
    return 0;
}
这种代码还超时

AC 

#include <stdio.h>
#include <math.h>
int main()
{
    int i,j,n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        for(j=pow(2.0*m,0.5);j>0;j--)
        {
            i=(2*m/j-j+1)/2;
            if(j*(2*i+j-1)==2*m)  printf("[%d,%d]\n",i,i+j-1);
        } 
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值