算法竞赛入门经典-前四章-UVa10055 - Hashmat the Brave Warrior-勇士Hashmat-难度1

题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=996

Problem A

Hashmat the brave warrior

Input: standard input

Output: standard output

 

Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.


Input

The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

 

Output

 For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

 

Sample Input:

10 12
10 14
100 200

 

Sample Output:

2
4
100

代码+分析:

/*
 *两个易错点:
 *  1) The input numbers are not greater than 2^32
 *     表示输入可以为2^32 > 2^32-1,int最大值,所以用long long int
 *  2) These two numbers in each line denotes the number of 
 *     soldiers in Hashmat's army and his opponent's army 
 *     or vice versa.
 *     or vice versa,表示输入的两个数不确定谁是谁的,但是HashMat的必然少。
 */
#include  <iostream>
using namespace std;

int main()
{
	//freopen("f:\\input.txt", "r", stdin);
    long long int a, b, c;
	while(cin >> a >> b)
	{
		 b - a > 0 ? c = b - a : c  = a - b; 
		 cout << c << endl;
	}
	return 0;
}


如果您正在使用 Spring Boot 3 和 micrometer-tracing-bridge-brave 进行 RabbitMQ 追踪,但无法获取到数据,可能是配置不正确或代码实现有误。 首先,您需要确保您的应用程序已正确配置 micrometer 和 rabbitmq。您可以在 `application.properties` 或 `application.yml` 配置文件中添加以下属性: ``` # micrometer management.metrics.export.tracing.enabled=true # rabbitmq spring.rabbitmq.host=localhost spring.rabbitmq.port=5672 spring.rabbitmq.username=guest spring.rabbitmq.password=guest ``` 接下来,您需要在您的代码中添加以下依赖: ```xml <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-core</artifactId> <version>${micrometer.version}</version> </dependency> <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-registry-prometheus</artifactId> <version>${micrometer.version}</version> </dependency> <dependency> <groupId>io.micrometer</groupId> <artifactId>micrometer-registry-tracing</artifactId> <version>${micrometer.version}</version> </dependency> <dependency> <groupId>io.zipkin.brave</groupId> <artifactId>brave</artifactId> <version>${brave.version}</version> </dependency> <dependency> <groupId>io.zipkin.brave</groupId> <artifactId>brave-instrumentation-messaging-rabbitmq</artifactId> <version>${brave.version}</version> </dependency> ``` 其中 `${micrometer.version}` 和 `${brave.version}` 分别是 micrometer 和 brave 的版本号。 最后,您需要在您的代码中使用以下代码进行跟踪: ```java @Bean public Tracing tracing() { return Tracing.newBuilder() .localServiceName("your-service-name") .propagationFactory(Propagation.B3_FACTORY) .build(); } @Bean public Tracer tracer(Tracing tracing) { return tracing.tracer(); } @Bean public RabbitTemplate rabbitTemplate(ConnectionFactory connectionFactory, Tracer tracer) { RabbitTemplate rabbitTemplate = new RabbitTemplate(connectionFactory); rabbitTemplate.setBeforePublishPostProcessors( TraceMessagePostProcessorBuilder .newInstance(tracer) .build() ); return rabbitTemplate; } ``` 这将创建一个跟踪实例,并在 RabbitMQ 消息发布之添加跟踪信息。 希望这可以帮助您解决问题。如果有任何进一步的问题,请随时问我。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值