算法竞赛入门经典-前四章-UVa445 - Marvelous Mazes-非凡的迷宫-难度1

题目链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=386


 Marvelous Mazes 

Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z* (asterisk), and spaces.

Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character.

The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of line.

Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.

There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.

Happy mazing!

Sample Input

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T
 
11X21b1X
4X1b1X

Sample Output

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T
 
XX   X
XXXX X

代码:

/*
 *1)Descriptions for different mazes will be separated by a blank line 
 *in both input and output.空行表示就是一个回车的行,没有空格。
 *2)The descriptions for different rows in the maze will be separated
 *  by an exclamation point (!) or by an end of line.表示以'!'或者'\n'为
 *  结束
 */
#include <iostream>
#include <string>
#include <cstdio>
#include <cctype>
using namespace std;

int main()
{
#ifdef LOCAL
	freopen("f:\\input.txt", "r", stdin);
#endif LOCAL
	char c;
	int count = 0;//用来记总的字数
	while(scanf("%c", &c) != EOF)//EOF end of file
	{
		if(isdigit(c))
		{
			count += c - '0';
		}
		else if(isupper(c) || c == '*')
		{
			while(count)
			{
				cout << c;
				count--;
			}
			/*
			 *如果用:
			 *while(count--)
			 *{
			 *  cout << c;
			 *}
			 *最后count为-1,所以还要把count置为0
			 */
		}
		else if(c == 'b')
		{
			while(count)
			{
				cout << " ";
				count--;
			}
		}
		else if(c == '!' || c == '\n')
		{
			cout << endl;
			count = 0;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值