字符串对比模拟

问题 O: typo

题目描述

You are given two strings S and T. Determine whether it is possible to make S and T equal by doing the following operation at most once:

choose two adjacent characters in S and swap them.
Note that it is allowed to choose not to do the operation.

Constraints
Each of S and T is a string of length between 2 and 100 (inclusive) consisting of lowercase English letters.
S and T have the same length.

输入

Input is given from Standard Input in the following format:

S
T

输出

If it is possible to make S and T equal by doing the operation in Problem Statement at most once, print Yes; otherwise, print No.

样例输入
【样例1】
abc
acb
【样例2】
aabb
bbaa
【样例3】
abcde
abcde
样例输出
【样例1】
Yes
【样例2】
No
【样例3】
Yes
#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
string s1, s2;
int main() {

    cin >> s1 >> s2;
    int cnt = 0;
    //int arr[3];

    int num = 0;
    for (int i = 0; i < s1.size(); i++)
    {
        if (s1[i]!=s2[i])
        {
            //arr[cnt] = i;
            cnt++;
            if (s1[i+1]!=s2[i+1]&&s1[i+1]==s2[i]&&s1[i]==s2[i+1])
            {
                num = 1;
            }
           
        }
    }
    //if (!cnt)
    //{
    //    cout << "Yes" << endl;
    //    return 0;
    //}
    if ((cnt == 2 && num==1)||cnt==0)
    {
        cout << "Yes" << endl;
    }
    else
    {
        cout << "No" << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值