将一系列给定数字顺序插入一个初始为空的二叉搜索树(定义为左子树键值大,右子树键值小),你需要判断最后的树是否一棵完全二叉树,并且给出其层序遍历的结果。
输入格式:
输入第一行给出一个不超过20的正整数N
;第二行给出N
个互不相同的正整数,其间以空格分隔。
输出格式:
将输入的N
个正整数顺序插入一个初始为空的二叉搜索树。在第一行中输出结果树的层序遍历结果,数字间以1个空格分隔,行的首尾不得有多余空格。第二行输出YES
,如果该树是完全二叉树;否则输出NO
。
输入样例1:
9
38 45 42 24 58 30 67 12 51
输出样例1:
38 45 24 58 42 30 12 67 51
YES
输入样例2:
8
38 24 12 45 58 67 42 51
输出样例2:
38 45 24 58 42 12 67 51
NO
#include<bits/stdc++.h>
using namespace std;
const int maxn=110;
typedef struct TreeNode{
int val;
struct TreeNode *left;
struct TreeNode *right;
}TreeNode;
TreeNode *insert(TreeNode *t,int x){
if(!t){
// cout<<"1"<<endl;
t=(TreeNode*)malloc(sizeof(TreeNode));
t->val=x;
t->left=t->right=NULL;
}
else{
// cout<<"2"<<endl;
if(x>t->val)t->left=insert(t->left,x);
else if(x<t->val)t->right=insert(t->right,x);
}
return t;
}
bool check(TreeNode *t){
queue<TreeNode *> q;
q.push(t);
int flag=1;
while(!q.empty()){
TreeNode *tt=q.front();q.pop();
if(tt!=t){
cout<<" "<<tt->val;
}
else cout<<tt->val;
if(tt->left!=NULL&&tt->right!=NULL){//左右都不空
if(flag==2){
flag=0;
}
q.push(tt->left);q.push(tt->right);
}
else if(tt->left==NULL&&tt->right!=NULL){//左空 右不空
flag=0;
q.push(tt->right);
}
else if(tt->left!=NULL&&tt->right==NULL){//左不空 右空
if(flag==2){
flag=0;
}
if(flag!=0){//还未确定不满足时在此处也要标记(出现空了)
flag=2;
}
q.push(tt->left);
}
else if(tt->left==NULL&&tt->right==NULL){//左空 右空
if(flag==1){//未标记则标记
flag=2;
}
}
}
return flag;
}
int main(){
TreeNode *T=NULL;
int n;cin>>n;
for(int i=0;i<n;i++){
int x;cin>>x;
T=insert(T,x);
}
if(check(T)){
cout<<"\nYES"<<endl;
}
else cout<<"\nNO"<<endl;
return 0;
}