ind the integer A such that pow(A,N) is as close as possible to B

Description
Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input: The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output: For each pair B and N in the input, output A as defined above on a line by itself.

Example Input: Example Output:
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0
1
2
3
4
4
4
5
16

解题思路:

因为最合适的A的N次方与B的绝对值是最小的,在A的逐渐增加过程中A的N次方与B的绝对值先是减小,当A取到合适的值后A再增加时,A的N次方与B的绝对值也越来越大,

所以当如果A+1的N次方与B的绝对值大于A的N次方与B的绝对值时,A为正确答案

细节处理:


代码:

#include <iostream>
#include<cmath>
using namespace std;
int main()
{
    double b,n;
    while(cin>>b>>n)
    {
        if(b==0&&n==0) break;
        int i;
        double x,y;
        x=fabs(b-1);
        for(i=2;;i++)
        {
            y=x;
            x=fabs(b-pow(i,n));
            if(x>=y) break;
        }
        cout<<i-1<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值