T

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input: The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output: For each pair B and N in the input, output A as defined above on a line by itself.

Example Input:Example Output:
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0
1
2
3
4
4
4
5
16
题意:

就是找到 最接近b的a的n次方,就是输出a

分析:

就是找一个数的n次方小于等于n这个数加一大于n,做差,找最接近的数,输出

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    long int b,n,i,x,y;
    while(cin>>b>>n&&n!=0&&b!=0)
    {
        for(i=1;i<=b;i++)
        {
            x=pow(i,n)-b;
            y=pow(i+1,n)-b;
            if(x<=0&&y>0)
            {
                if(fabs(x)<fabs(y))
                    cout<<i<<endl;
                else
                    cout<<i+1<<endl;
                break;
            }
        }
    }
    return 0;
}

感受:

这个题不知道怎么回事,老是不过,一直就是segmentation fault ,我感觉好像不能用数组,好像是开的太大了,反正就是交了10次才过发火发火

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值