1(好好理解)poj1837(01背包)

http://poj.org/problem?id=1837

Balance
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 7171Accepted: 4321

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4 
-2 3 
3 4 5 8

Sample Output

2

Source

 

题意:输入一个天平若干(<=20)挂钩的位置,将若干(<=20)砝码挂到天平上,问有多少种使天平挂平衡的方法。这次至少是读懂题意了,以前做的时候连题都没有读懂,还是问的龄姐,不过当时还是不大明白为什么就是01背包..现在明白了,砝码只有两种选择要么放要么不放,这不就是01背包的特征吗?想到这里就是要怎么把这题抽象成01背包的模型,01背包一般都是有一个容量的限制,往里面装最大的价值。而这题是要求使得天平挂平衡的方法的个数。确实转不过来。脑子局限于容量的思想,怎么也想不出怎么建立转移方程还是看看神姐的解释http://www.cnblogs.com/lyy289065406/archive/2011/07/31/2122629.html

dp[i][v]表示悬挂i个砝码是所能达到v值得方法数

d[i][j]默示在挂上前i个物体的时,均衡度为j
* (j>0时默示左边重,j=0时默示天均匀衡,j<0时默示右边重)时挂法的数量,
* 而按照题意可以断定j的取值局限为:[-7500,7500],于是可以获得状况转移方程为:
      d[i][j]+=(d[i-1][j-weigh[k]*pos[i]]),
         weigh[k]默示第k个挂钩的地位,pos[i]为第i个砝码的重量
    因为j-weigh[k]*pos[i]可能为负数,是以同一加上7500,
    那么初始状况d[0][7500]=1(此时默示天均匀衡),默示不消物体且使得天均匀衡时的办法只有一种.
http://www.cppblog.com/snowshine09/archive/2011/08/02/152258.html?opt=admin

http://sfiction.blog.163.com/blog/static/1994040102012454308398/

#include<iostream>
#include<cstring>
using namespace std;
const int max1=7500,max2=50;
int c,g,weight[max2],pos[max2],d[max2][max1*2];
int main()
{
 while(cin>>c>>g)//c挂钩数g钩码数
 {
  int i,j,k;
  for(i=1;i<=c;i++)
   scanf("%d",&pos[i]);
  for(i=1;i<=g;i++)
   scanf("%d",&weight[i]);
  memset(d,0,sizeof(d));
  d[0][max1]=1;//7500为天枰达到平衡状态时的平衡度//放入前0个物品后,天枰达到平衡状态7500的方法有1个,就是不挂钩码
  for(i=1;i<=g;i++)
  {
   for(j=0;j<=max1*2;j++)
   {
    for(k=1;k<=c;k++)//状态数组dp[i][j]放入(挂上)前i个物品(钩码)后,达到j状态的方法数
     d[i][j]+=d[i-1][j-weight[i]*pos[k]];
   }
  }
  printf("%d\n",d[g][max1]);//放入g个钩码时平衡的个数
 }
 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值