HDOJ2602(DP0-1背包)

http://acm.hdu.edu.cn/showproblem.php?pid=2602

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11339 Accepted Submission(s): 4370


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDOJ2602(DP0-1背包)


 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.


 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).


 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1


 

Sample Output
14


 

Author
Teddy


 

Source


 

Recommend
lcy
具体解法我就不说了。。不会的看背包九讲(重温这题就是为了弄解法1的)不过有三个小问题要注意。。f数组一定要初始化,要不然WA。。还有就是 return f[m]与return f[n];居然都能AC。。这个我暂时不理解。。。不过还是建议return f[m]..三.是由于题目并没有要求一定要把背包装满所以数组初始化的时候 应该将 f[0..V] 全部设为 0。
解法1:
15MS292K574 B
#include<stdio.h>
#include<string.h>
int
n ,m ;
int
f [ 2010 ],weight [ 2010 ],cost [ 2010 ];
int
max ( int x , int y )
{

    return
x >y ?x :y ;
}

int
zeroonepack ( int cost , int weight )
{

    int
i ;
    for
(i =m ;i >=cost ;i --)
              f [i ]=max (f [i ],f [i -cost ]+weight );
    return
f [n ];
}

int
main ()
{

    int
t ;
      scanf ( "%d" ,&t );
    while
(t --)
    {

              scanf ( "%d %d" ,&n ,&m );
        int
i ;
        for
(i = 1 ;i <=n ;i ++)
                      scanf ( "%d" ,&weight [i ]);
        for
(i = 1 ;i <=n ;i ++)
                      scanf ( "%d" ,&cost [i ]);
              memset (f , 0 , sizeof (f ));//这一步一定不可少
        for
(i = 1 ;i <=n ;i ++)
                      zeroonepack (cost [i ],weight [i ]);
              printf ( "%d\n" ,f [m ]);
    }

    return
0 ;
}
 
解法2
15MS264K484 B
#include<stdio.h>
#include<string.h>
int f[2010]={0},c[1010],w[1010];
int
max(int x,int y)
{

    if
(x>y)return x;
    else return
y;
}

int
main()
{

    int
T;
    scanf("%d",&T);
    while
(T--)
    {

        int
n,v,i,j;
        scanf("%d %d",&n,&v);
        for
(i=1;i<=n;i++)
            scanf("%d",&w[i]);
        for
(i=1;i<=n;i++)
            scanf("%d",&c[i]);
        memset(f,0,sizeof(f));
        for
(i=1;i<=n;i++)
        {

            for
(j=v;j>=c[i];j--)
                f[j]=max(f[j],f[j-c[i]]+w[i]);
        }

        printf("%d\n",f[v]);
    }

    return
0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值