0.8poj1971(排序||数学题)

http://poj.org/problem?id=1971

Parallelogram Counting
Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 5334Accepted: 1783

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6

Source

题意:求在若干个点中能找到几个平行四边形。
想法:一开始是想用斜率来做的后来发现网上都是用中点做的。说下斜率做的思路,
(1)把任意两个点的斜率求出来(也就是两个for()循环),细节相同两个顶点会算两次,所以加个判断条件就行了。
(2)找任意两队满足斜率相等(还要判断不在一条直线上这个再在任意一组里面任选一个顶点求斜率和原来的比,不相同就满足条件)。大体思路就是这样,具体还没有实现。
 
现在给网上惯用的思路就是通过平行四边形的性质,中点啊。
平行四边形的对角线也是角平分线,通过三角形相等,可得对角线的交点也为俩对角线的中点。即可根据此,求出任意两点连线的中点,假设有n条直线的中点相同,则平行四边形的个数为c(n,2),这个还是好理解的就是在n个满足条件的顶点里面任意找2就行了。。因为每两条交线确定一个平行四边形。
1971Accepted4184K1954MSC++990B
  #include<iostream>
#include<algorithm>
using namespace std;
struct node
{
int x;
int y;
};
node plane[1010]; node middle[5000000];
int comp(node a,node b)//x按照从大到小排序
{
if(a.x ==b.x )//x相等按y由大到小
return a.y <b.y ;
return a.x <b.x ;//x按照从大到小排序
}
int main()
{
int cases;
int n;
int i,j,k;
int sum;
int  total;
int flag;
cin>>cases;
while(cases--)
{
cin>>n;
for(i=0;i<n;i++)
cin>>plane[i].x>>plane[i].y ;
k=0;//******************
for(i=0;i<n-1;i++)//把中点坐标保存在middle[]数组
{
for(j=i+1;j<n;j++)
{
middle[k].x =plane[i].x+plane[j].x ;
middle[k].y =plane[i].y +plane[j].y;
k++;
}
}
sort(middle,middle+k,comp);//从大到小排序
flag=0;
total=0;
sum=1;
for(i=1;i<k;i++)
{
if(middle[i].x ==middle[flag].x &&middle[i].y ==middle[flag].y )//中点坐标相等
sum++;
else
{
flag=i;//更新flag
total+=sum*(sum-1)/2;//关键***计算公式
sum=1;//及时清除
}
}
cout<<total<<endl;
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值